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1. Introduction 
PaletteWB is a MS Windows software application for generating, importing, and converting color palettes. Conversion
can be performed "in batch" for multiple files. Palettes can be also saved as .gif-files. In addition, PaletteWB can
load or generate images, apply a new color map to them, and if wanted, export them as a color cycling .gif-file. The
following palette formats are supported for im- and export:

• GIMP palette (*.gpl);

• Adobe Photoshop palette (*.aco);

• Fractint palette (*.map);

• Microsoft palette (*.pal);

• A hexadecimal color list (*.hextxt).

The following formats can be exported only, but not read:

• HTML (as a table) (*.html);

• CSS color list (*.css);

• JavaScript list (*.js).

The following methods for generating palettes are implemented:

• A cosinus-based approach as described in Inigo Quilez' article about palettes.

The following methods for generating images are implemented:

• Mandelbrot fractals;

• Julia fractals.

The following methods for manipulating palettes are implemented:

• adjust Brightness / Contrast;

• adjust Hue / Saturation / Value;

• invert index order;

• shift index order by an offset;

• apply the "Persian Raster" method.

This document is the user manual for PaletteWB, version 1.4. It contains information that explains what PaletteWB
was designed for and how to use it.

PaletteWB was tried to be designed to please its users. We hope for a feedback on this. Please give us a notice about
your experience with PaletteWB using the contact possibilities located at http://www.palettewb.com/. We would also
be very lucky to be informed about errors within the application or mistakes in the documentation.

This user documentation is structured as following: Chapter 2 gives an introduction into color palettes and what
PaletteWB is. Chapter 3 describes the interaction possibilities using PaletteWB's graphical user interface. The
document closes with appendices that lists the supported palette types and the available formatting options.
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2. Color palettes and PaletteWB 
Initially, computer images ("bitmaps") had a limited number of colors. Each pixel was not holding a value for red,
green, and blue (RGB) as nowadays, but was rather pointing to a colour in a colour table. Such image formats, where
each pixel points to an entry in a colour palette are called indexed images. The colour table itself is called "palette",
"colour map" or "colour palette".

As usual, different formats for storing colour palettes were developed. PaletteWB's main application is to convert
between different formats.

Nowadays, colour palettes can be found in .gif-images, which store indexed colour images. As known, .gif-images
are capable to store animations as well. Generating images by colourcycling - rotating the colour map - is the second
main application for PaletteWB.

In addition, PaletteWB can generate palettes and can generate as well example images, mainly for testing colour
cycling.
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3. Contact and Further Information 
PaletteWB has a web page at http://www.palettewb.com/. You may contact us by writing to info@palettewb.com.
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4. PaletteWB's Graphical User
Interface 
4.1. Overview
The main window is divided into two sections, an image viewer part and a colour map viewer part. Additionally, a
menu bar and a tool bar exist that allow further interaction. The following image shows this graphical interface, its
usage is described in the following.

Figure 4.1. Main PaletteWB window

4.2. Image Viewer
After starting the application or if an image was closed (see "Close Image"), the viewer is empty. As soon as an image
was loaded (see "Open Image") or the user has generated an image (see "Image Generation"), the image is displayed
within the viewer.

The user can zoom into (see "Zoom In (25%)") the image and out (see "Zoom Out (25%)") of image. The view can
be restored to its original size (see "Normal Size").

4.3. Menu Bar

4.3.1. The "File" Menu
The File menu allows you to load and save images and colour palettes from/to different formats. Additionally, a loaded
palette can be exported as a gif-image. The File menu contains the following entries:

• Open Palette...: a window opens which allows you to choose a palette file to load. After selecting the file and clicking
"OK" or double-clicking the file within the window, the palette will be loaded and shown in the palette viewer.

• Save Palette: If a palette was loaded and modified you can save the changed palette by choosing this item. If the
palette was not saved before, a window will be shown where you can select the folder to save the palette into and
define the palette's file name. As well, this dialog enables you to select the format under which you want the palette
to be saved under.
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• Save Palette As...: Choosing this item will show a window where you can select the folder to save the palette into
and its name. As well, this dialog enables you to select the format under which you want the palette to be saved.

• Export Palette...: A dialog is opened that allows you to name the file to save and to define the format to use.
Afterwards, a further dialog, specific for the selected export format, is opened, see "Exporting Palettes".

• Open Image...: A window opens which allows you to choose an image file to load. After selecting the file and
clicking "OK" or double-clicking the file within the window, the image will be loaded and shown in the image
viewer after being computed.

• Save Image: If an image was loaded and modified you can save the changes by choosing this item. If the image
was not saved before, a window will be shown where you can select the folder to save the image into and define
the image's file name.

• Save Image As...: Choosing this item will show a window where you can select the folder to save the image into
and define the image's file name.

• Close Image...: Choosing this item will remove the image from the image viewer. If the image was generated or
modified, you will be asked whether you want to save the image before.

• Exit: Quits the application

4.3.1.1. Exporting Palettes

Most palette formats are fixed. Yet, when exporting palettes to .css or to .js-files, additional format options can be
set. This is also true when generating .gif-images that show the palettes. The individual options are described in the
following.

4.3.1.1.1. Exporting Palettes to JSON

When exporting palettes to .js/.json-files the following dialog will be shown.

Figure 4.2. JSON export dialog

You can define the following:

• Variable name: the name of the variable under which the palette will be exported; you may either give the name of
the variable, or use one of the format strings as shown in Format String Variables.

• Entry format: sets the format used to store the palette; when choosing "hex", the palette entries will be saved as hex-
triplets (with a '#' appendix), e.g. "#ffff00" for yellow; when choosing "triplet", each palette entry will be stored as
an array of the R, G, B value, e.g. [255, 255, 0] for yellow.

4.3.1.1.2. Exporting Palettes to CSS

When exporting palettes to .css-files the following dialog will be shown.
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Figure 4.3. CSS export dialog

You can define the following:

• Entry name: defines the CSS-selectors under which the colors will be stored; you may use the format strings as
shown in Format String Variables; please note that the name should include the '%i' field for setting the index of
each palette entry;

• Attribute: defines the CSS-attribute to set.

4.3.1.1.3. Exporting Palettes to GIF

When exporting palettes as .gif-images the following dialog will be shown.

Figure 4.4. GIF export dialog

You can define the following:

• Cell Width: defines the width of a cell (area showing a single colour) in pixels;

• Cell Height: defines the height of a cell in pixels;

• Column Number: defines the number of columns.

4.3.2. The "Image" Menu
Here, you can find items for generating images, converting images to indexed images and for exporting a colorcycling
animation

• Generate: Opens a sub-menu where the method to use for image generation can be chosen; see Image Generation.

• Convert: Opens a sub-menu that contains actions for converting the image to indexed colors or to a grayscale image,
see Image Conversion.

• Export Animation: Opens a menu that controls how the image shall be exported to a colourcycling gif-image, see
Export Animation.

4.3.2.1. Image Generation

Currently, PaletteWB offers two ways to generate an image. They will be described in the following.
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4.3.2.1.1. Mandelbrot

When choosing the menu entry "Image -> Generate -> Mandelbrot" the following dialog will be shown.

Figure 4.5. Mandelbrot fractal generation dialog

At the top of the dialog you may find presets you can select from.

The dialog offers additional controls for changing the selected area and setting the size of the image to generate:

• X-offset: position of the center of the shown part of the Mandelbrot area along the x-axis;

• Y-offset: position of the center of the shown part of the Mandelbrot area along the y-axis;

• Zoom: the used zoom factor;

• Iterations: the maximum iteation number;

• Scale: the palette repetition scale;

• Width: the width of the image to generate;

• Height: the height of the image to generate.

The view is interactive. You can move the shown part when pressing the left mouse button and moving the mouse.
You can use the mouse scroll wheel to zoom in/out. You may as well move the shown area with the cursor keys and
zoom in/out using the keys '+' and '-', respectively.

Pressing "Reset" will reset the view to the first preset. Pressing "OK" generates the defined image, optionally asking
whether the previous image shall be saved. "Cancel" will close the dialog without generating an image.

For further information about Julia sets, see the Wikipedia article about Mandelbrot sets.

4.3.2.1.2. Julia

When choosing the menu entry "Image -> Generate -> Julia" the following dialog will be shown.
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Figure 4.6. Julia fractal generation dialog

At the top of the dialog you may find presets you can select from.

The dialog offers additional controls for changing the selected area and setting the size of the image to generate:

• Real: the real part of the investigated z;

• Imag: the imaginary part of the investigated z;

• X-offset: position of the center of the shown part of the Julia area along the x-axis;

• Y-offset: position of the center of the shown part of the Julia area along the y-axis;

• Zoom: the used zoom factor;

• Iterations: the maximum iteation number;

• Scale: the palette repetition scale;

• Width: the width of the image to generate;

• Height: the height of the image to generate.

The view is interactive. You can select a new z by pressing the right mouse button within the area, you can as well
move the mouse while holding the right button. You can move the shown part when pressing the left mouse button
and moving the mouse. You can use the mouse scroll wheel to zoom in/out. You may as well move the shown area
with the cursor keys and zoom in/out using the keys '+' and '-', respectively.

Pressing "Reset" will reset the view to the first preset. Pressing "OK" generates the defined image, optionally asking
whether the previous image shall be saved. "Cancel" will close the dialog without generating an image.

For further information about Julia sets, see the Wikipedia article about Julia sets.
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4.3.2.2. Image Conversion

PaletteWB can convert not indexed RGB-images into indexed images for applying colour palettes to them.

4.3.2.2.1. Greyscale

The loaded image will be converted into a greyscale image. The brightness of each pixel is set to the average of the
pixel's original RGB components. The palette will be set to a greyscale palette.

4.3.2.2.2. Indexed

The loaded image will be quantized and converted into an indexed 8bit-image. The palette will be obtained from the
quantized colors of the image.

4.3.2.3. Export Animation

This option allows to generate gifs animated by colorcycling. It can only be chosen, if an indexed image has been
loaded or if a loaded image was converted to an indexed one.

When selected, a window that allows to select a filename to save the animation to is shown. After entering or selecting
a valid filename, the following dialog is shown:

Figure 4.7. Animation export dialog

Here, you can define the start and the end indices between which the palette shall be rotated. Additionally, the animation
speed stored in the .gif file can be changed.

4.3.3. The "Palette" Menu
The "Palette" menu contains entries for generating palettes, for manipulating them, and for converting palettes in batch.

• Generate: opens a sub-menu where a method for generating a new palette can be chosen; see Palette Generation.

• Adjust colors: opens a sub-menu where a method for changing the colors of the palette can be chosen; see Color
adjustment.

• Reorder: opens a sub-menu where a method for changing the order of the palette's colors can be chosen; see
Reordering indices.

• Batch Convert ...: opens a dialog which allow to select palettes for batch conversion and controls how that should
be done, see Batch Convert.

4.3.3.1. Palette Generation

Currently, PaletteWB includes the possibility to generate palettes using a cosinus-based approach. It is described in
the following.
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4.3.3.1.1. Using Cosini

When choosing the menu entry "Palette -> Generate -> Using Cosini ..." the following dialog will be shown.

Figure 4.8. Dialog for generating a palette using Cosini

The dialog offers additional controls for changing the selected area and setting the size of the image to generate:

You can change the parameters of the cosinus functions for the R, G, and B components.

For further information about generating palettes this way, see Inigo Quilez' article about palettes.

4.3.3.2. Color Adjustment

Currently, PaletteWB supports the following color adjustment options:

• Brightness / Contrast ...: see Brightness / Contrast.

• Hue / Saturation / Value ...: see Hue / Saturation / Value.

They are described in the following.

4.3.3.2.1. Brightness / Contrast

When choosing the menu entry "Palette -> Adjust Colors -> Brightness / Contrast ..." the following dialog will be
shown.

Figure 4.9. Dialog for changing the palette colors' brightness and contrast

You can change the following parameters:

• Brightness: changes the brightness of the colors;

• Contrast: changes the contrast between colors.
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4.3.3.2.2. Hue / Saturation / Value

When choosing the menu entry "Palette -> Adjust Colors -> Hue / Saturation / Value ..." the following dialog will
be shown.

Figure 4.10. Dialog for changing the palette colors' hue, saturation, and values

You can change the following parameters:

• Hue: changes the colors' hue;

• Saturation: changes the colors' saturation;

• Value: changes the colors' value.

If the "Colorize" checkbox is set, the hue will be directly applied instead of changing it.

4.3.3.3. Reordering Indices

Currently, PaletteWB supports the following options for changing the order of a palette's colors:

• Invert Order: inverts the order of the palette's entries, see Invert Order.

• Shift by Offset ...: shifts the entries by an offset, see Shift by Offset.

• Persian Raster ...: a repetition pattern is applied, see Persian Raster.

They are described in the following.

4.3.3.3.1. Invert Order

When choosing the menu entry "Palette -> Reorder -> Invert Order" the order of the palette's colors will be inverted.

4.3.3.3.2. Shift by Offset

When choosing the menu entry "Palette -> Reorder -> Shift by Offset ..." the following dialog will be shown.

Figure 4.11. Dialog for shifting the palette color indices by an offset
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You can change the following parameters:

• Offset: changes the offset to shift the entries by.

4.3.3.3.3. Persian Raster

When choosing the menu entry "Palette -> Reorder -> Persian Raster ..." the following dialog will be shown.

Figure 4.12. Dialog for applying the Persian Raster repetition pattern

You can change the following parameters:

• Offset: the offset to the first color entry used;

• Fin Height: the height of the fins;

• Between Fin Increment: the index increment between the fins;

• Inner Fin Increment: the index increment within a fin.

See this blog entry about Persian rasters for further information.

4.3.3.4. Batch Convert

This option allows you to convert multiple palettes in batch. When selecting "Palette -> Batch Convert...", the following
dialog is shown:
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Figure 4.13. Dialog for batch conversion

This dialog allows you to select the individual files as well as folders. When selecting folders, all found palette files
stored within them will be converted. Whether a file is a palette file or not is determined by the file's extension. Using
the "Assume file format:" option, you can force PaletteWB to convert only certain types of palettes. The "Convert
to:" option allows you to set the format to convert the palettes to. The extension used by this file format will be
automatically set. When exporting, some palette formats can have additional options, see Exporting Palettes. They can
be set using the "Extended Settings" option.

4.3.4. The "View" Menu
Here, the zoom at a loaded/generated image can be changed:

• Zoom In (25%): Increases the zoom factor by 25%.

• Zoom Out (25%): Decreases the zoom factor by 25%.

• Normal Size: Resets the zoom factor to normal size.

4.3.5. The "Help" Menu
Contains basic information about the application.

• About: Shows some information about the application.

4.4. Tool Bar
The tool bar contains shortcuts to the following menu entries which also can be found within the menu bar and were
described previously:

• Open Palette...

• Save Palette

• Save Palette As...
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• Open Image...

• Save Image

• Save Image As...

• Export Animation...

• Batch Convert...
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Appendix A. Supported Palette Types
The following table shows which palette formats are known by PaletteWB.

Table A.1. Palette formats that can be imported and exported

Palette Format Extension Can be read Can be written

GIMP palette gpl yes yes

Adobe Photoshop palette aco yes yes

Fractint palette map yes yes

Microsoft palette pal yes yes

A hexadecimal color list hextxt yes yes

JavaScript list js no yes

CSS color list css no yes

HTML (as a table) html no yes
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Appendix B. Formatted String
Variables
At some places, a FORMAT_STRING is used. The string may contain placeholders for current values, e.g. the color
table entry's index. The following placeholders are supported:

Table B.1. FORMAT_STRING variables

Palette Format Extension

%f the filename without extension

%n the name of the palette if given in the file, otherwise the
file name (%f)

%i the index of the palette entry
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